Бърз и лесен начин за инсталиране на видео драйвери в Debian

Статии свързани с настройката на хардуерни устройства и инсталиране на драйвери.

Модератори: Freya, Kulu Ngile

Мнениеот tishovo » Пет 03, Апр, 2009 9:09

В момента има някакви проблеми със зависимостите. Проблема ми беше следния: На новоинсталирана система(лаптоп)Debian/Sid
Код за потвърждение: Избери целия код
mybox:~# cat /etc/debian_version
squeeze/sid
mybox:~# uname -a
Linux mybox 2.6.29-bozata-0.1 #1 SMP Fri Mar 27 20:03:02 EET 2009 i686 GNU/Linux
mybox:~# lspci | grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]
пускам скрипта sgfxi, той си тегли ATI 9.3 drivers, инсталира и вобще минава всичко привидно гладко, обаче fglrxinfo ми казва vendor Mesa, и естествено
Код за потвърждение: Избери целия код
 mybox:~# glxinfo | grep rendering
direct rendering: Нанайси, моля опитайте по-късно пак ...
:shock:Ееегасиии... Това ме обезпокои защото много рядко, но се случва да поцъкам 3D игричка. Пробвах всички описани начини в нета за инсталиране на несвободни драйвери, копирах разни библиотеки тук и там, но все греда, няколко дена направо стана гредоред. Накрая се оказа, че в Debian/Sid са обновили libdrm2 до версия 2.4.5-2, а тя бърка fglrx драйвера. Решението беше downgrade до версия 2.3.1-2 от Debian/Lenny
Код за потвърждение: Избери целия код
aptitude install libdrm2/stable

След което пуснах пак sgfxi и нещата си дойдоха по местата :mrgreen:
Също така описах в /etc/apt/preferences:
Код за потвърждение: Избери целия код
mybox:~# cat /etc/apt/preferences
Package: libdrm2
Pin: version 2.3.1-2
Pin-Priority: 1001

...зада няма изненади след apt-get upgrade. Ето и линк към бъг репортите по въпроса.
tishovo
Участник
 
Мнения: 4
Регистриран на: Сря 10, Сеп, 2008 15:12

Мнениеот aleximilian » Съб 30, Яну, 2010 14:24

На скоро установих без да искам, че с новите драйвъри на NVIDIA вече и с включен tv-out, compiz работи. Гаранция, че при 190.53 работят, за по-стари версии не знам.
Е, това е, честито на тези който искат да се наслаждават на compiz и да си гледат някакво видео на телевизора си :)
[center]БЪЛГАРИЯ[/center]

Малко филмче

Неволи

# apt-get remove --purge windows
Аватар
aleximilian
Участник
 
Мнения: 112
Регистриран на: Сря 11, Фев, 2009 3:07

Мнениеот Ninja7a » Чет 09, Фев, 2012 22:59

имам няколко вапроса по това за видеото
1.когато излезна от х и се логна като роот не ми дава да изключа графичната среда (gdm3) а когато съм влезнал в терминала ми я изклучва..

2.След като съм изклучил gdm3 и излезна от х и се логна като роот изпалнявам дова кодче но нещо се прецаква кода които изпалнявам е

c
Код за потвърждение: Избери целия код
cd /usr/local/bin && wget http://techpatterns.com/downloads/distro/sgfxi && chmod +x sgfxi && sgfxi
Ninja7a
Участник
 
Мнения: 67
Регистриран на: Пон 09, Яну, 2012 14:25

Мнениеот phantomlord » Пет 10, Фев, 2012 15:06

не разбирам първия ти въпрос... Като излезеш от Х, излизаш от графичната среда.
За втория - без да ни дадеш изхода от командата, не можем да ти помогнем.
Hear the cry of War
Louder than before
With his sword in hand
to control the land
Crushing metal strikes
on this frightening night
Fall onto your knees
For the Phantom Lord
Аватар
phantomlord
Шеф
 
Мнения: 1517
Регистриран на: Пет 03, Мар, 2006 1:16
Местоположение: София

Мнениеот Ninja7a » Съб 11, Фев, 2012 15:50

Ще ти опиша всичко подробно..

1. натискам Ctrl+alt+F2
2.После се логвам като root
3. пиша
Код за потвърждение: Избери целия код
 /etc/init.d/gdm3 stop


след това ми се появява първия erorr
Код за потвърждение: Избери целия код
Stopping GNOME Mamager: gdm3start-stop-daemon: warning: failed to kill 1122: Operation not premitted


4.а когато реша да пусна последния код за инсталирането а кода е

Код за потвърждение: Избери целия код
cd /usr/local/bin & wget http://techpatterns.com/downloads/distro/sgfxi && chmod +x sgfxi && sgfxi


след като го напиша и дам ентер ми излиза този ерорр..

Код за потвърждение: Избери целия код
--2012-02-11 15:21:56-- http://techpatterns.com/downloads/distro/sgfxi
Преобразувам techpatterns.com... 209.197.72.47
Connecting to techpatterns.com | 209.197.72.47 | :80... успешно свързан.
HTTP изпратено искане, чакам отговор... 301 Moved Permanently
Адрес: http://smxi.org/sg/sgfxi [следва]
--2012-02-11 15:21:56-- http://smxi.org/sg/sgfxi
Преобразувам smxi.org... 209.197.72.47
Reusing existing connection to techpatterns.com:80.
HTTP изпратено искане, чакам отговор... 200 ок
sgfxi: Отказан достъп

Cannot write to `sgfxi` (Отказан достъп).



Да уточня с видео карта ATI Radeon 9600 съм .
Ninja7a
Участник
 
Мнения: 67
Регистриран на: Пон 09, Яну, 2012 14:25

Мнениеот Ninja7a » Нед 12, Фев, 2012 17:26

това се оправи сложих диска на ново го инсталнах и се оправи само че като написха последното кодче

Код за потвърждение: Избери целия код
cd /usr/local/bin & wget http://techpatterns.com/downloads/distro/sgfxi && chmod +x sgfxi && sgfxi


В последните няколко реда ми се появява това

ERORR: (221) had dropped fglrx non-free driver supportt for your card type as of driver release 9-4
Only cards x2000 or newer are now supported by MD/ATI for this driver.
If you know your card is supported, please let the sgfxi maintainer know.
You can override yhis test with -! 6 option. If install works, let maintainer know.

Log file is located here: /var/log/sgfxi.log
Exiting script now.
Ninja7a
Участник
 
Мнения: 67
Регистриран на: Пон 09, Яну, 2012 14:25

Мнениеот aleximilian » Нед 12, Фев, 2012 19:34

Все си мисля, че някъде нещо много малко бъркаш и за това не ти се получават нещата.
Освен инсталиране на видео драйвър с този скрипт, може и ръчно да го инсталираш. Потърси го тук.
Но като за начало, си преведи какво значи ERROR 221 и покажи съдържанието тук:
Код за потвърждение: Избери целия код
cat /var/log/sgfxi/sgfxi.log

Ако си решил твърдо да го инсталираш от скрипта, разгледай тук.
[center]БЪЛГАРИЯ[/center]

Малко филмче

Неволи

# apt-get remove --purge windows
Аватар
aleximilian
Участник
 
Мнения: 112
Регистриран на: Сря 11, Фев, 2009 3:07

Мнениеот Ninja7a » Нед 12, Фев, 2012 21:34

=========================================================
START sgfxi LOGGING:
=========================================================
Script started: 2012-02-11-20:14:43
Video Card Information: ATI Technologies Inc RV350 AP [Radeon 9600]
Video Card Type: 1002
Video Card Number: 4150
Xorg Version: 1.7
Installing driver to kernel: 2.6.32-5-686
sgfxi script version: 4.17.79
sgfxi start options:
SYSTEM_BASE: debian
SYSTEM_CODENAME: stable
DISTRIB_CODENAME: stable
DISTRIB_ID: debian
DISTRIB_RELEASE:
FG_DISTRIB_CODENAME: squeeze
FG_DISTRIB_ID: Debian
APT_TYPE: apt-get
=========================================================
X is Running: false
Current Runlevel: 2
Connection is live (0=true): 0
=========================================================
INSTALL_TO_KERNEL:
KERNEL_FULL: 2.6.32-5-686
KERNEL_BASE: 2.6
KERNEL_NUMBER: 2.6.32
KERNEL_MATH: 32
B_IS_XEN: false
Function: create_x_conf - Primary: Start
xorg is present, no xorg.conf file
Function: x_is_running - Utility: Start
xIsRunning: false
Function: x_is_running - Utility: End
Function: x_is_running - Utility: Start
xIsRunning: false
Function: x_is_running - Utility: End

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-5-amd64 i686 Debian
Current Operating System: Linux Dexter 2.6.32-5-686 #1 SMP Mon Jan 16 16:04:25 UTC 2012 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-686 root=UUID=88f6a1a3-ab49-45be-9dee-ab52b6580776 ro quiet
Build Date: 30 October 2011 08:56:49PM
xorg-server 2:1.7.7-14 (Julien Cristau <jcristau>)
Current version of pixman: 0.16.4
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 11 20:14:49 2012
List of video drivers:
neomagic
vmwlegacy
apm
i128
cirrus
vesa
vmware
i740
chips
ati
tdfx
nouveau
savage
siliconmotion
ark
openchrome
nv
sisusb
tseng
trident
ztv
mga
radeon
s3virge
s3
rendition
sis
fglrx
r128
intel
mach64
voodoo
geode
fbdev
vmware: Please ignore above "FATAL: Module vmwgfx not found."
(EE) No supported AMD display adapters were found
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"


Xorg detected your mouse at device /dev/input/mice.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.

Your xorg.conf file is /root/xorg.conf.new

To test the server, run 'X -config /root/xorg.conf.new'

xorg.conf created and mv to /etc/X11/
xorg xorg.conf file generated
Function: create_x_conf - Primary: End
Function: check_package_manager_updated - Utility: Start
sizeWorking: 14
Function: check_package_manager_updated - Utility: End
Function: check_supported_driver - Utility: Start
Function: check_supported_driver - Utility: End
Function: set_cpu_data - Utility: Start
BITS: 32 - arch: i386
Function: set_cpu_data - Utility: End
Function: set_driver_install_version - Primary: Start
Function: check_supported_driver - Utility: Start
Args: last-check
Function: check_supported_driver - Utility: End
Function: print_information_continue - Utility: Start
Args: standard The graphics installer will be installing the fglrx driver: 12-1
Function: print_information_continue - Utility: End
Installing this driver: 12-1
Function: set_driver_install_version - Primary: End
Function: driver_support_tests - Utility: Start
Args: supported-driver
ERROR: (221) AMD/ATI had dropped fglrx non-free driver support for your card type as of driver release 9-4
Only cards x2000 or newer are now supported by AMD/ATI for this driver.
If you know your card is supported, please let the sgfxi maintainer know.
You can override this test with -! 6 option. If install works, let maintainer know.
Ninja7a
Участник
 
Мнения: 67
Регистриран на: Пон 09, Яну, 2012 14:25

Мнениеот Ninja7a » Нед 12, Фев, 2012 22:03

В първото сайтче не ми дава да свалям...
а пък във второто не успях да намеря нищо... Така, че ако може малко помощ.. Благодаря все пак :)
Ninja7a
Участник
 
Мнения: 67
Регистриран на: Пон 09, Яну, 2012 14:25

Мнениеот phantomlord » Пон 13, Фев, 2012 11:18

Грешката:
ERROR: (221) AMD/ATI had dropped fglrx non-free driver support for your card type as of driver release 9-4
Only cards x2000 or newer are now supported by AMD/ATI for this driver.

означава, че АТи вече не предлагат драйвери за твоята видеокарта.
Тук има описание как можеш да пробваш да сложиш по-стари драйвери, виж частта отнасяща се за Lenny (Debian 5.0): Catalyst 8.12 (fglrx 8.561):
http://wiki.debian.org/ATIProprietary
Hear the cry of War
Louder than before
With his sword in hand
to control the land
Crushing metal strikes
on this frightening night
Fall onto your knees
For the Phantom Lord
Аватар
phantomlord
Шеф
 
Мнения: 1517
Регистриран на: Пет 03, Мар, 2006 1:16
Местоположение: София

Мнениеот Ninja7a » Вто 14, Фев, 2012 14:58

Аз не съм с лени аз сам с GNU/linux debian 6.0
Ninja7a
Участник
 
Мнения: 67
Регистриран на: Пон 09, Яну, 2012 14:25

Мнениеот phantomlord » Чет 16, Фев, 2012 15:29

Знам, че не си... Просто за тази версия има драйвери за твоето видео. Може да пробваш с тях все пак.
Hear the cry of War
Louder than before
With his sword in hand
to control the land
Crushing metal strikes
on this frightening night
Fall onto your knees
For the Phantom Lord
Аватар
phantomlord
Шеф
 
Мнения: 1517
Регистриран на: Пет 03, Мар, 2006 1:16
Местоположение: София

Мнениеот Ninja7a » Пон 20, Фев, 2012 21:11

Нестава!!!! някакви съвети :(
Ninja7a
Участник
 
Мнения: 67
Регистриран на: Пон 09, Яну, 2012 14:25

Мнениеот phantomlord » Вто 21, Фев, 2012 9:48

А какво става?
Hear the cry of War
Louder than before
With his sword in hand
to control the land
Crushing metal strikes
on this frightening night
Fall onto your knees
For the Phantom Lord
Аватар
phantomlord
Шеф
 
Мнения: 1517
Регистриран на: Пет 03, Мар, 2006 1:16
Местоположение: София

Мнениеот Ninja7a » Вто 21, Фев, 2012 22:29

инсталира ми Debian leny и ми стават два дебиана
Ninja7a
Участник
 
Мнения: 67
Регистриран на: Пон 09, Яну, 2012 14:25

ПредишнаСледваща

Назад към Настройка на хардуер

Кой е на линия

Потребители разглеждащи този форум: 0 регистрирани и 0 госта

cron